Ask DaBoom & Wolf

Even after (or during) reading our guides and exploring the links, we know that you will have questions and need clarification on various issues. Perhaps you’ve even checked out our FAQ, but don’t see your question answered there. Ask away! That’s what we’re here for.

Don and Eric are pretty knowledgeable, but we’re not know-it-all’s. If we’re not sure, we’ll point you in the right direction.

Enter your question in the Leave a Reply box below and we’ll post our answer. [NOTE: This is not live chat. We check in here frequently, but expect some delay in receiving your answer.]


  1. Rottweiler Jim says:

    I bought 4 Aspire bdc ce5 clearo’s with 1.8ohm coils a month ago. Used on my Vamo V3 and after a couple days I saw the resistance rise to 2.0,2.3… and after about 5 days 5.8 ohms. I tried cleaning and air dry for 2 days before dry burning I checked resistance still over 5ohms. As I started to see the coils glow it was 6.3. I let it cool awhile then the coils poped. I checked the new clearo I was using for 2 days it was at 2.7 already and the same was happening with the rest. My juices were cinnomin, honey dew, flan custard and tobacco. The cinnomin was the only thick juice and all are 70/30/18mg. All the reviews rave the Aspires bdc and I love them too but when a coil last only 5 days and can’t rebuild them someting aint right. Of all my time vaping i’ve only seen a rise of maybe 0.3 ohms after a month of use at most. Am I the only one noticing this? For 1.8 ohms I usualy use 3.4v-3.7v or 5.0w-7.5w max.

    • Eric says:

      That’s unfortunate. Are you certain that they were genuine Aspire? I just checked an Aspire BDC that I’ve been using for about 4 weeks (although in rotation with other devices) and it shows the same 1.8 ohms that it started with. That’s with 80/20 juice an never cleaned. I’m not sure what the cause may be.

  2. carol says:

    Hi there.
    I recently purchased a starter kit from platinum vapes. I am new to vaping so I asked a lot of questions at the shop and they were very helpful and helped me set it up. So Ive had it for about a week and Ive used it a couple of days. I noticed that aftwr about 5 or 6 hits the mouthiece tip gets kind of warm. Is that normal? I try not to use it for a little while because im scared it will get hotter and hotter. I also notice that sometimes when I hit it it seems to spark or almost shock my tongue or shoot something into my mouth. That sort of scared me. Is that something normal or is my starter kit defective? Thanks for your time. I tried searching for answers but I havent come across any information on what Im experiencing.

    • Eric says:

      Carol, it really depends on the type of kit you have and I’m not familiar with Platinum vapes. Some cartomizers and in particular atomizers do get hot on the lips after repeated vapes. The shocking sensation is not normal unless you are referring simply to getting a shot of warm juice in your mouth. Again, some types of cartomizers have a tendency to do that.

  3. glenda says:

    how can I unsweeten a mixture

  4. Julie says:

    haha, checking intelligence is scarey..I recently purchased an eVic and the screen keeps indicating an “over 10s” display..what does that mean and how can I fix it? Also, it frequently warns of temperature, even if I wait a while before vaping..any help out there? Given that I’m a blonde and a newbie to this product, I sincerely need all the help I can get 😉
    Warm regards,

    • Eric says:

      Julie, my assumption would be that the over 10s is indicating that you are holding the button in for more than 10 seconds. Is it possible that the button is stuck? I would suggest you pose your question in the Evic section over at ECF. There will be lots of Evic users there who hopefully can help you. If you’re not already active on ECF then you will need to reach a 5 post minimum before you can post to the sub-forum, but getting to know people there is well worth the effort.

  5. Dart says:

    Hello, An ego kit arrived recently and I filled it with RY4 and started vaping. Soon it started clogging and above the liquid it was misty. I swabbed the battery and lightly cleaned the threads but still wouldn’t vape. I stopped using it and transferred the liquid to another clearomizer. Is it defective or should I wash it out and try again?

    • Eric says:

      My advice will depend largely upon the type of cartomizer or clearomizer you have. Testing with a multimeter to see if there is any resistance is the best way to see if that one is ready for the trash or not.

  6. Pete says:

    i recently got a $60 tank with a fill port in the top cap, so that sliding the carto out on refills would be unneccesary. On my 1st refill i removed the tiny screw from the fill port, and before i could even get my already full of eLiquid syringe into the fill port the remaining liquid in the tank all poured out the bottom of the cartomizer !! i realize that this probably was due to the sudden change in “vacuum” in the tank once the fill port became an “air hole” but i searched everywhere for how to properly fill these type tanks and came up empty. Am thinking to try putting toothpicks into both ends of the carto next time? Really would appreciate any advice you may have. Thank you.

    • Eric says:

      That is strange. Usually it is the reverse that happens when the pressure from sealing up the tank forces more juice into the carto. What type of cartomizer are you using? Is is a CE type without filler, by chance?

  7. Tamera White says:

    I use kr808 Volt and Bloog sealed batteries and am wondering if there is a different, more effective way to clean them than what I’m doing. There is a ring around the seal, and then the ridges on the outside where you screw on the cart. The ring around the seal on the inside gets a greenish gunk around it and is very difficult to clean. I use a paper towel and safety pin and run it around and believe I get most of it out, but it certainly doesn’t look shiny new. I also run a paper towel around the grooves around the outside and run the safety pin end into the holes to keep them opened up. Do you know of a better way to clean the ring around the sealed portion inside?

    • Eric says:

      A little bit of rubbing alcohol will help a lot. I use a qtip pretty well soaked with it and run it around all the areas you mentioned. You can shake the excess alcohol out of the battery, but it evaporates quickly anyway.

  8. Tiffany says:

    Hi, I have an OMG mod from vapor4life with the 18650 battery and extender. I love the mod so far, although its only my second one I’ve had. The tanks are new to me and they keep leaking into the threaded part that it screw onto and makes it hard to vape freely. I have to keep unscrewing it and cleaning it out and putting it back on. Its annoying!! The only thing that seems to help is when I put my eliquid in, and fill it up, then it wont leak anymore until it goes down bout half away again. It seems like I am wasting allot of liquid that way. Do you have any ideas to help with this? I tried changing the tank, but they all seem to do it. HELP! 🙂

    • Eric says:

      What type of tank are you using? The OMG mods come with basic cartomizer tanks. They are not prone to leaking. If that is what you are using, you may want to try a locking tank (UDCT) which is essentially the same, but locks on the bottom. New cartos might help as well.

Leave a Reply